
Accela SDK for Android
Version 3.0

 

GETTING STARTED 
GUIDE



Accela SDK for Android Getting Started Guide

© 2013 Accela, Inc. All rights reserved. 

Accela, the Accela logo, the Accela logo with “Government Software” notation, Accela Automation, Accela 
Asset Management, Accela Citizen Access, Accela Mobile Citizen Access, Accela ERS, Accela GIS, Accela 
IVR, Accela Land Management, Accela Licensing, Accela Mobile Office, Accela Public Health and Safety, 
Accela Service Request, Accela Wireless, Kiva DMS, Kiva Development Management System, 'PERMITS' 
Plus, SiteSynch, Tidemark Advantage, VelocityHall, Vantage360, and other Accela logos, devices, product 
names, and service names are trademarks or service marks of Accela, Inc. Brava! Viewer is a trademark of 
Informative Graphics Corporation. Windows is a registered trademark of Microsoft Corporation. Acrobat is a 
trademark of Adobe Systems Incorporated. Portions copyright 2009 Ching-Lan 'digdog' Huang and digdog 
software. All other company names, product names, and designs mentioned herein are held by their 
respective owners.

Version 3.0
August 2013

Corporate Headquarters

2633 Camino Ramon
Suite 120
Bishop Ranch 3
San Ramon, CA 94583

Tel: (888) 722-2352 
Fax: (925) 659-3201

www.accela.com

http://www.accela.com


3

TABLE OF CONTENTS
Preface .......................................................................................................4

Revision History ................................................................................................ 4

Getting Help ...................................................................................................... 4

Related Publications ......................................................................................... 5

Documentation Feedback ................................................................................. 5

Getting Started with Accela SDK for Android ........................................6

Setting Up Environment for Android Development ........................................... 6

Registering Applications on Accela Developer Portal....................................... 6

Installing Accela SDK and Creating Projects .................................................... 8

Downloading and Running a Sample Project ................................................. 17



4

PREFACE
The Accela SDK for Android is designed to be easy to install and use. This guide walks you 
through the basics of setting up the development environment and using the SDK or project 
template to create an app.

Revision History
This revision history table summarizes changes made during each release of this document for 
version 3.0 of Accela SDK for Android.

Getting Help
If you need technical assistance, one of your best resources is the Accela Customer Resource 
Center (CRC). There, you can search the knowledge base to find answers to commonly asked 
questions about our products. You can also register to use the Accela Forum where you can 
find a wealth of practical information from other Accela users, as well as participate in dynamic 
information exchange.

If you still have questions after visiting Accela’s CRC site, or if you encounter any problems as 
you use the product, contact your agency administrator. 

If you determine that you need professional technical assistance, have your agency’s 
designated contact call the CRC at (888) 7-ACCELA, ext. 5 or (888) 722-2352 ext. 5. The 
Accela CRC is available Monday through Friday from 6:00 AM to 6:00 PM (PST/PDT).

Before calling, please have the following information available for the CRC representative: 

 The Accela product name and version number.

 Steps to replicate the issue, including any error message or error number.

 Screen shots, if possible.

 Whether the problem is specific to a machine or to a user.

 Exactly when the problem began.

 Anything that changed on your computer or network (for example, new software was 
loaded).

 Table 1: Revision History

Date Description

August 2013 Updated to the latest terminology and user interfaces

May 2013 Initial document release

www.accela.com/support
www.accela.com/support
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 A copy of your configuration file, if appropriate.

Related Publications
Accela provides a set of SDK documents for agency and third-party developers.

 Login - Getting Started (online help)

Documentation Feedback
Accela wants to provide you with the most accurate and useful documentation possible. We 
welcome your feedback in helping us improve future versions of this guide. Send an e-mail 
message with your feedback to documentation@accela.com. Please include the product name 
and version number, whether the feedback involves a printed manual or online help, the topic 
title, and a brief description and context of the suggestion.

mailto: documentation@accela.com
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GETTING STARTED WITH ACCELA

SDK FOR ANDROID
The Accela SDK for Android is designed to be easy to install and use. This guide walks you 
through the basics of setting up the development environment.

Topics

 Setting Up Environment for Android Development

 Registering Applications on Accela Developer Portal

 Installing Accela SDK and Creating Projects

 Downloading and Running a Sample Project

Setting Up Environment for Android Development
Before developing applications with Accela SDK on Android operating system, you need to set 
up environment for Android development first. For detailed procedure of setting up environment 
for Android development, see http://developer.android.com/sdk/installing/installing-adt.html.

Registering Applications on Accela Developer Portal

To register applications on Accela Developer portal

1. Log in to the Accela developer portal.

Note: When setting up the environment, add the Android Support 
Library. It is required because Accela SDK refers to some 
classes in the library. For more information about Android 
Support Library, see http://developer.android.com/tools/extras/
support-library.html.

http://developer.android.com/sdk/installing/installing-adt.html
http://developer.android.com/tools/extras/support-library.html
http://developer.android.com/tools/extras/support-library.html


Accela SDK for Android Getting Started Guide
Registering Applications on Accela Developer Portal 7
2. Navigate to the My Apps tab.

3. Click the Add New App button.

The Add New App window appears.

4. Fill in the fields.

Targeted Users If you want to create an app for agencies, select the Agency 
App button; if you want to create an app for citizens, select the 
Citizen App button.

App Name Enter the app name.

App Description Enter the descriptions of the app.

Stage Enter the development stage of the app. You can choose Under 
Development or Published in the drop down list.
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5. Click the Submit button.

The My Apps window appears.

Installing Accela SDK and Creating Projects
Install Accela SDK and import it to your Android project so that you can develope applications 
for agencies or citizens with Accela SDK. There are two approaches to achieve this goal.

Approach 1: Installing Accela SDK through Eclipse Plugin
To install Accela SDK through Eclipse plugin and create a template project, implement the 
following tasks in order.

Topics:

 Task I: Installing Accela SDK

 Task II: Creating Projects with Accela SDK

App Secret The app secret is generated automatically. Remember the value 
of the app secret and it will be required when setting up your app 
with Accela SDK.

Enabled Mark the check box to enable the app or clear the check box to 
disable the app.

Note: Remember the value of the App ID because it will be required 
when setting up applications with Android SDK.
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Task I: Installing Accela SDK
There are two ways to install Accela SDK:

 To install Accela SDK on line through Eclipse plugin

 To install Accela SDK off line through Eclipse plugin

To install Accela SDK on line through Eclipse plugin

1. Start Eclipse.

2. Choose Help > Install New Software.

The Install window appears.

3. Click the Add button.

The Add Repository window appears.

4. Enter the Accela SDK name, for example, Accela Mobile. Enter the location, https://
developer.accela.com/sdk/android. And then click the OK button.

The list of available Accela SDK components appears.

https://developer.accela.com/sdk/android
https://developer.accela.com/sdk/android
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5. Mark the check boxes next to the Accela Inc. components.

6. Step through the wizard.

Now the Accela SDK plugin is installed in Eclipse. You can continue with the next steps to 
create a template project.

To install Accela SDK off line through Eclipse plugin

1. Download the Accela SDK offline installation package at https://developer.accela.com/sdk/
android.zip, then unzip it to a local disk.

2. Start Eclipse.

3. Choose Help > Install New Software.

4. Click the Add button.

5. Click the Local... button.

The Browse For Folder window appears.

https://developer.accela.com/sdk/android.zip
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6. Browse and select the folder mentioned in step 1 of this section. Enter the Accela SDK 
name, and click the OK button.

The list of available Accela SDK components appears.

7. Mark the check boxes next to the Accela Inc. components and step through the wizard.

Task II: Creating Projects with Accela SDK

To create a project with Accela SDK through Eclipse plugin

1. Choose File > New > Project.

The New Project window appears.

2. Select a project type corresponding to the type of app which you created in step 4 of the 
Registering Applications on Accela Developer Portal chapter. For example, if you select the 
Agency App button in the step 4 of the Registering Applications on Accela Developer 
Portal chapter, choose “Agency App Wizard” here. 
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3. Click the Next button.

The Agency App Wizard window appears.

4. Fill in the fields. In this step, you need to use the App ID created in step 5 and App Secret 
created in step 4 of the Registering Applications on Accela Developer Portal chapter.

5. Click the Next button.

The following window appears.

6. Enter the project name, choose a location, and then click the Finish button.

Now the Accela Agency App template project is created. The project name appears on the 
project tree panel. As it is a complete Android project, you can run it directly.

Note: The Android SDK Version means the Android API level on which 
the application runs so make sure the corresponding version of 
Android SDK is installed before selecting an API level. 
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Approach 2: Integrating Accela SDK into Android Project 
Manually

To integrate Accela SDK into Android project manually, implement the following tasks in order.

Topics:

 Task I: Downloading Accela SDK for Android on Accela Developer portal

 Task II: Creating Android Project Manually

 Task III: Importing Accela SDK into Android Project Manually

Task I: Downloading Accela SDK for Android on Accela 
Developer portal

To download Accela SDK for Android on Accela Developer portal

1. Log in to the Accela Developer portal. 

2. Navigate to the Resources tab.

3. Click the Download Accela SDK for Android link in the Android Resources list.

4. Save the downloaded SDK file AccelaSDK.jar to a local disk.

Task II: Creating Android Project Manually

To create an android project manually

Take creating an Android project named “InspectionViewer” for example.

1. Start Eclipse. 

2. Choose File > New > Android Project. 

The New Android Project dialog appears.
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3. Enter “InspectionViewer” as the project name, click the Create new project in workspace 
option button, select the Use default location check box, and then click the Next button.

The dialogue box for selecting build target appears.

4. Select Android 2.3.3 (API level 10) or a later version as the build target. Click the Next 
button.

The dialogue box for application information appears.
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5. Fill in the information.

6. Click the Finish button.

7. Update the Android Manifest XML file for Accela Mobile specific configurations.

a. Locate the AndroidManifest.xml file in the project navigation panel and open it.

Application Name Enter the Application name, for example, “InspectionViewer”.

Package Name Enter the package name, for example, “com.accela”.

Create Activity Whether to create activities. In this example, mark the Create 
Activity check box, and enter “ActivityInspection”.

Minimum SDK Choose the minimum version number of SDK, for example, “10”.

Create a Test Project Whether to create a test project. In this example, unmark the 
check box.
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b. Add the following content after the </application> element node:

<uses-permission android:name="android.permission.INTERNET" />

c. Add the declaration of AuthorizationActivity within the </application> element node; 
otherwise, you will be unable to invoke authorization page, then unable to log in to the 
Android application.

<activity android:name="com.accela.mobile.AuthorizationActivity"  
android:windowSoftInputMode="stateHidden" > 

  <intent-filter>

    <action android:name="android.intent.action.VIEW"></action>

<category ndroid:name="android.intent.category.DEFAULT"></
category>

<category android:name="android.intent.category.BROWSABLE"></
category>

<data android:scheme="amtest" android:host="authorize"></data>

  </intent-filter>            

</activity>

Task III: Importing Accela SDK into Android Project Manually

To import Accela SDK into Android project manually

1. Locate the home directory of your project, for example, D:\workspace\app\.

2. Add a new folder, “libs”.

3. Copy the AccelaSDK.jar file to the “libs” folder.

4. Press the F5 key on the keyboard to refresh the project tree view. 

Now the Accela SDK is imported into the project.

5. Update the Android Manifest XML file for Accela Mobile specific configurations. For detailed 
procedure, refer to step 7 of the Installing Accela SDK and Creating Projects chapter.
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Downloading and Running a Sample Project
Accela offers you a sample project on the Accela Developer Portal. The sample project 
demonstrates the common features that you can integrate into an Android app via the Accela 
SDK for Android.

To download and run a sample project

1. Navigate to the Resources tab on the Accela Developer Portal.

2. From the Android Resources list, click the Download Sample Applications link.

3. Save the sample project package (*.zip) into your local drive.

4. Open Eclipse and run the sample project.
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